[Cake] Trouble with CAKE

Thibaut hacks at slashdirt.org
Fri Dec 13 08:43:29 EST 2019

Hi list,

I've been using CAKE on my DSL-connected Linux router for the last few years, and it worked well until very recently. Two things happened:

1) My ISP (French "Free") switched my DSLAM to native IPv6, which for the time being means that I had to revert to using their set-top-box (Freebox) instead of the VDSL2 model I was using in bridge mode until then (CAKE in "bridged-ptm ether-vlan" mode)
2) I upgraded my router from 3.16 (Devuan Jessie) to 4.9 (Devuan ASCII)

Since then, no matter which setup I use, I cannot get CAKE to work as intended. Specifically, any long-standing best effort stream (such as a remote rsync) will be throttled to a near grinding halt even though there is no other significant traffic going on. Some random bursts can be seen (with iftop) but nothing ever gets close to half the maximum bandwidth. This is notably affecting the OpenWRT buildbots I'm hosting on this link.

In details:

$ uname -a
Linux rapid-ts1 4.9.0-11-686 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) i686 GNU/Linux

Cake commit: 183b320 RFC 8622 diffserv3, 4 & 8 LE PHB support

cake setup on the wan iface: bandwidth 1Mbit diffserv3 dual-srchost nat nowash ack-filter split-gso bridged-vcmux no-sce
the available ATM uplink bandwith is 1.2Mbps, I tried going as low as 700kbps, disabling ack-filter and setting "conservative" to see if it would make a difference, it wouldn't in any significant way: the upload would still be severely throttled. I also tried disabling the ingress leg to get that out of the equation: also no difference.

As I broke rule #1 of any setup upgrade (by changing both the link - VDSL to ADSL - and the running kernel), I can't tell for sure where the fault lies; however I must add something about the "native IPv6 DSLAM" bit:

Free uses map-e/map-t, i.e. ipip6 tunnels on its native v6 DSLAMs. The Freebox still offers a public IPv4 to the connected router, but inside the Freebox there is an ipip6 tunnel setup to encapsulate the IPv4 traffic into IPv6, a tunnel over which I have no control. I wonder if this encapsulation and its associated overhead could be throwing CAKE computations off? FWIW, my router now operates in dual-stack mode, with both a public IPv4 and a public IPv6 (although for the time being my LAN remains IPv4 only).

I haven't (yet) found a way to connect directly to the DSLAM without the Freebox (using my VDSL modem as I did before), so I can't get around this particular blackbox.

I hope this provides enough detail, I'm happy to expand as needed: I would really want my CAKE back :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.bufferbloat.net/pipermail/cake/attachments/20191213/ebb264d9/attachment.html>

More information about the Cake mailing list