[Cerowrt-devel] IPv6 doesn't work as well with 3.3.8-17

Richard Brown richard.e.brown at dartware.com
Sat Aug 25 01:11:11 EDT 2012


On Aug 24, 2012, at 10:03 PM, Dave Taht wrote:

> post your radvd.conf file, please.

Here it is. Thanks.

=======================
root at OpenWrt:/etc/config# cat radvd

config interface
	option interface 'se00'
	option AdvSendAdvert '1'
	option AdvRouterAddr '1'
	option AdvLinkMTU '1480'
	option ignore '0'
	option IgnoreIfMissing '1'
	option AdvSourceLLAddress '1'
	option AdvDefaultPreference 'medium'
	option AdvOtherConfigFlag '1'

config prefix
	option interface 'se00'
	list prefix ''
	option AdvOnLink '1'
	option AdvAutonomous '1'
	option AdvRouterAddr '0'
	option ignore '0'

config interface
	option interface 'sw00'
	option AdvSendAdvert '1'
	option AdvRouterAddr '1'
	option AdvLinkMTU '1480'
	option ignore '0'
	option IgnoreIfMissing '1'
	option AdvSourceLLAddress '1'
	option AdvDefaultPreference 'medium'
	option AdvOtherConfigFlag '1'

config prefix
	option interface 'sw00'
	list prefix ''
	option AdvOnLink '1'
	option AdvAutonomous '1'
	option AdvRouterAddr '0'
	option ignore '0'

config interface
	option interface 'sw10'
	option AdvSendAdvert '1'
	option AdvRouterAddr '1'
	option AdvLinkMTU '1480'
	option ignore '0'
	option IgnoreIfMissing '1'
	option AdvSourceLLAddress '1'
	option AdvDefaultPreference 'medium'
	option AdvOtherConfigFlag '1'

config prefix
	option interface 'sw10'
	list prefix ''
	option AdvOnLink '1'
	option AdvAutonomous '1'
	option AdvRouterAddr '0'
	option ignore '0'

config interface
	option interface 'gw00'
	option AdvSendAdvert '1'
	option AdvRouterAddr '1'
	option AdvLinkMTU '1480'
	option ignore '0'
	option IgnoreIfMissing '1'
	option AdvSourceLLAddress '1'
	option AdvDefaultPreference 'medium'
	option AdvOtherConfigFlag '1'

config prefix
	option interface 'gw00'
	list prefix ''
	option AdvOnLink '1'
	option AdvAutonomous '1'
	option AdvRouterAddr '0'
	option ignore '0'

config interface
	option interface 'gw10'
	option AdvSendAdvert '1'
	option AdvRouterAddr '1'
	option AdvLinkMTU '1480'
	option ignore '0'
	option IgnoreIfMissing '1'
	option AdvSourceLLAddress '1'
	option AdvDefaultPreference 'medium'
	option AdvOtherConfigFlag '1'

config prefix
	option interface 'gw10'
	list prefix ''
	option AdvOnLink '1'
	option AdvAutonomous '1'
	option AdvRouterAddr '0'
	option ignore '0'

config rdnss
	option ignore '0'
	option interface 'se00'

config dnssl
	option ignore '0'
	option interface 'se00'
	list suffix 'home.lan'

config rdnss
	option ignore '0'
	option interface 'sw00'

config dnssl
	option ignore '0'
	option interface 'sw00'
	list suffix 'home.lan'

config rdnss
	option ignore '0'
	option interface 'sw10'

config dnssl
	option ignore '0'
	option interface 'sw10'
	list suffix 'home.lan'

config rdnss
	option ignore '0'
	option interface 'gw00'

config dnssl
	option ignore '0'
	option interface 'gw00'
	list suffix 'home.lan'

config rdnss
	option ignore '0'
	option interface 'gw10'

config dnssl
	option ignore '0'
	option interface 'gw10'
	list suffix 'home.lan'
=============================


> 
> On Fri, Aug 24, 2012 at 6:23 PM, Richard Brown
> <richard.e.brown at dartware.com> wrote:
>> More testing...
>> 
>> I can get sw10 to work (to hand out an IPv6 address), but my MacBook doesn't get an IPv6 address when plugged into se00 (the wired interface). I have appended the /etc/config/network file that I'm using.
>> 
>> I get the same result if the last two lines are changed to:
>> 
>>        list adv_interface 'se00'
>>        list adv_interface 'sw10'
>> 
>> [To reprise, I'm trying to use the script at http://www.bufferbloat.net/projects/cerowrt/wiki/IPv6_Tunnel to configure all the HE.net tunnel parameters automatically. That script gives an error "command failed: Device or resource busy (-16)" after it handles sw00 and gw00, and then again after it does sw10 and gw10. I also get these errors when I "/etc/init.d/network restart" with the config file below.]
>> 
>> Any suggestions? Thanks.
>> 
>> Rich Brown
>> Hanover, NH USA
>> 
>> =======================================
>> root at OpenWrt:~# cat /etc/config/network
>> 
>> config interface 'loopback'
>>        option ifname 'lo'
>>        option proto 'static'
>>        option ipaddr '127.0.0.1'
>>        option netmask '255.0.0.0'
>> 
>> config interface 'se00'
>>        option ifname 'se00'
>>        option proto 'static'
>>        option ipaddr '172.30.42.1'
>>        option netmask '255.255.255.224'
>>        option ip6addr '2001:470:8a63:100::1/64'
>> 
>> config interface 'ge00'
>>        option ifname 'ge00'
>>        option proto 'dhcp'
>> 
>> config interface 'sw00'
>>        option type 'none'
>>        option proto 'static'
>>        option ipaddr '172.30.42.65'
>>        option netmask '255.255.255.224'
>>        option ip6addr '2001:470:8a63:300::1/64'
>> 
>> config interface 'sw10'
>>        option type 'none'
>>        option proto 'static'
>>        option ipaddr '172.30.42.97'
>>        option netmask '255.255.255.224'
>>        option ip6addr '2001:470:8a63:200::1/64'
>> 
>> config switch
>>        option name 'rtl8366s'
>>        option reset '1'
>>        option enable_vlan '0'
>>        option blinkrate '2'
>>        option max_length '3'
>> 
>> config switch_vlan
>>        option device 'rtl8366s'
>>        option vlan '1'
>>        option ports '0 1 2 3 5t'
>> 
>> config switch_port
>>        option device 'rtl8366s'
>>        option port '1'
>>        option led '6'
>> 
>> config switch_port
>>        option device 'rtl8366s'
>>        option port '2'
>>        option led '9'
>> 
>> config switch_port
>>        option device 'rtl8366s'
>>        option port '5'
>>        option led '2'
>> 
>> config interface 'gw00'
>>        option type 'none'
>>        option proto 'static'
>>        option ipaddr '172.30.42.129'
>>        option netmask '255.255.255.224'
>>        option ip6addr '2001:470:8a63:400::1/64'
>> 
>> config interface 'gw10'
>>        option type 'none'
>>        option proto 'static'
>>        option ipaddr '172.30.42.161'
>>        option netmask '255.255.255.224'
>>        option ip6addr '2001:470:8a63:500::1/64'
>> 
>> config interface 'gw01'
>>        option proto 'ahcp'
>>        option ip6addr '2001:470:8a63:600::1/64'
>> 
>> config interface 'gw11'
>>        option proto 'ahcp'
>>        option ip6addr '2001:470:8a63:700::1/64'
>> 
>> config interface 'henet'
>>        option proto '6in4'
>>        option peeraddr '209.51.161.14'
>>        option ip6addr '2001:470:1f06:64::2/64'
>>        option tunnelid 'dddddd'
>>        option username 'YOUR-USERNAME'
>>        option password 'YOUR-PASSWORD'
>>        option adv_subnet '1'
>>        option adv_interface 'se00'
>>        option adv_interface 'sw10'
>> 
>> 
>> 
>> _______________________________________________
>> Cerowrt-devel mailing list
>> Cerowrt-devel at lists.bufferbloat.net
>> https://lists.bufferbloat.net/listinfo/cerowrt-devel
> 
> 
> 
> -- 
> Dave Täht
> http://www.bufferbloat.net/projects/cerowrt/wiki - "3.3.8-17 is out
> with fq_codel!"
> 





More information about the Cerowrt-devel mailing list