[Cerowrt-devel] ADSL Issue (PPPoE)

William Katsak wkatsak at gmail.com
Mon Jul 30 14:34:37 EDT 2012


I am playing with a CeroWRT (3.3.8-6) router on my vacation in Russia and am
seeing some weird behavior with simple_qos.sh that I am unsure if I
should attribute to a
bug, or to an Internet connection that is "just that bad".

- The router is on my wife's parents' ADSL line (according to the modem,
~3000/500). The modem is a D-Link DSL-2500U.

- Even though the link is 3000/500, and I can get speedtest.net to
report 2.5mbps/0.42mbps on a clean connection (direct or Cero with no
QOS on), as soon as I use a host that is outside of Rostelecom (local
service), it drops to 0.9/0.4mbps. This is consistent with Netalyzr
test: Upload 430 Kbit/sec, Download 970 Kbit/sec. This suggests that
even though the DSL link is higher bitrate, the ISP doesn't have the
outgoing bandwidth or is rate-limiting it somehow.

- I don't necessarily intend to leave the router running Cero here,
but I want to get a handle on the latency situation, as it makes Skype
pretty messy...I am hoping to roll what I learn into a more stable
build of OpenWRT.

I have tried several different configurations of the modem including:
1) Default: Modem does PPPoE and hands out 192.168.1.xxx addresses. I
tried just letting Cero route through that address.
2) PPP-IP extension: This has the effect of the modem handling the
PPPoE connection and handing out the single "real" IP address over
DHCP. In this case Cero would see the Internet IP on ge00.
3) Bridging: Allow Cero to establish the PPPoE connection and manage it.

Right now I am in PPP-IP extension mode on the modem, and GUI QOS on
the router. This seems to be reliable and also keeps the latency down,
although I would imagine that PPPoE on the router and the GUI QOS
would be fine too, but obviously I would rather use simple_qos.

The problem:

When I try simple_qos.sh, I see this:

insmod: can't insert 'cls_fw': File exists
insmod: can't insert 'sch_htb': File exists
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory

If I run it again, the RTNETLINK errors go away...I assume this is
just an annoyance.

This gives me super stable ping times, etc. but a lot of websites hang
loading, and the connection is unusable. If I reboot the router, the
connection works fine again, although the high latency comes back.

So, with all that out there, I have some questions with simple_qos:

1) If I am using PPPoE on the router, do I need to do IFACE=pppoe-ge00
or still just ge00?
2) Should I set PPOE to "yes"?
3) Is it possible that no matter what I do, the buffers at the speed
drop between Rostelecom and their bandwidth provider is hurting me
4) If 3, what to do other than yell at them?

Overall, is anyone using Cero with a PPPoE connection with good
results? What kind of configuration do you have?

Sorry for the info dump, but if there is indeed a problem going on
with PPPoE connections, I am more than willing to be a guinea pig
until August 10th. I would appreciate any ideas!


-Bill Katsak

More information about the Cerowrt-devel mailing list