[Cerowrt-devel] dnsmasq ipv6 stuff

Richard Brown Rich.Brown at intermapper.com
Thu Jan 24 20:47:21 EST 2013


Folks,

I'm still confused about using CeroWrt 3.7.3-2 to give out v6 addresses to my laptop (it's not working). Here's what I see:

- I'm using the HE.net 6in4 tunnel to get a /48 for my home. The router itself has a good v6 address, and can ping global v6 addresses. 

- ifconfig in the router shows that each of the five interfaces (se00, sw00, sw10, gw00, gw10) have addresses assigned from my /48 (see the network file below).

- The only uncommented lines in the /etc/dnsmasq.conf file are a "enable-ra" and a set of dhc-range lines for each of the interfaces. (see below) The prefixes for each of the interfaces match the prefixes in the ifconfig command.

- I have not modified /etc/config/dhcp, as it didn't seem to make any difference what I put there.

Any thoughts? Thanks.

Rich

=====================================
root at OpenWrt:/etc# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'se00'
	option ifname 'se00'
	option proto 'static'
	option ipaddr '172.30.42.1'
	option netmask '255.255.255.224'
	option ip6assign '64'

config interface 'ge00'
	option ifname 'ge00'
	option proto 'dhcp'

config interface 'ge01'
	option ifname '@ge00'
	option proto 'dhcpv6'
	option broadcast '1'
	option metric '2048'
	option reqprefix '60'

config interface 'sw00'
	option type 'none'
	option proto 'static'
	option ipaddr '172.30.42.65'
	option netmask '255.255.255.224'
	option ip6assign '64'

config interface 'sw10'
	option type 'none'
	option proto 'static'
	option ipaddr '172.30.42.97'
	option netmask '255.255.255.224'
	option ip6assign '64'

config switch
	option name 'rtl8366s'
	option reset '1'
	option enable_vlan '0'
	option blinkrate '2'
	option max_length '3'

config switch_vlan
	option device 'rtl8366s'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_port
	option device 'rtl8366s'
	option port '1'
	option led '6'

config switch_port
	option device 'rtl8366s'
	option port '2'
	option led '9'

config switch_port
	option device 'rtl8366s'
	option port '5'
	option led '2'

config interface 'gw00'
	option type 'none'
	option proto 'static'
	option ipaddr '172.30.42.129'
	option netmask '255.255.255.224'
	option ip6assign '64'

config interface 'gw10'
	option type 'none'
	option proto 'static'
	option ipaddr '172.30.42.161'
	option netmask '255.255.255.224'
	option ip6assign '64'

config interface 'gw01'
	option proto 'ahcp'

config interface 'gw11'
	option proto 'ahcp'

config interface 'henet'
	option proto '6in4'
	option mtu '1424'
	option ttl '64'
	option peeraddr '209.51.161.14'
	option ip6addr '2001:470:1f06:64::2/64'
	option ip6prefix '2001:470:8a63::/48'
	option tunneled 'xxxxxx'
	option username 'tbxxxxx'
	option password 'xxxxx

==================
root at OpenWrt:/etc# cat /etc/dnsmasq.conf 
# Added 24Jan2013 -reb
enable-ra
dhcp-range=se00,2001:470:8a63:2::,ra-stateless,ra-names
dhcp-range=sw00,2001:470:8a63:3::,ra-stateless,ra-names
dhcp-range=sw10,2001:470:8a63:4::,ra-stateless,ra-names
dhcp-range=gw00,2001:470:8a63:0::,ra-stateless,ra-names
dhcp-range=gw10,2001:470:8a63:1::,ra-stateless,ra-names






More information about the Cerowrt-devel mailing list