[Cerowrt-devel] just when I thought it was safe to do a release

Dave Taht dave.taht at gmail.com
Wed Feb 19 12:01:41 EST 2014

The methods of assigning ipv6 addresses have changed somewhat
(possibly obsoleting the relevant scripts)



for more details.

All you should have to do is add the he interface, and leverage the
already set ip6assign parameter
for the normal interfaces, and add he to  the firewall rules for ge00.
Not sure if that latter step is
still needed....

AHCP still has to get manually configured, which is a PITA.

( note that I started building the new hnetd, ohybridproxyd, mdnsd
code in this build as downloadable packages. Hopefully these will end
up being the replacements for border discovery and ahcpd, and avahi.
But there is a long way to go, documentation is sparse (aside from the
relevant RFCs), developers few, feel free to explore them)

There are other ipv6 tricks you can play, not all of which appear to be working.

IF you are running native ipv6, you can stop routing dns over ipv4
with the peerdns parameter.

config interface 'ge00'
        option ifname 'ge00'
        option proto 'dhcp'
        option peerdns '0' # disable getting dns servers over ipv6

DON'T do this unless you are running native ipv6.

As for stuff that doesn't work...

For example, I tried to leverage ip6hints to statically assign
different ranges of addresses, didn't work.

I thought this would theoretically let me distribute he's addresses to
an internal gw that didn't get
dhcpv6 stuff. It worked, but I didn't get a default route that worked.
(doesn't mean that it won't work
for you, my network is running so much beta code that I have no idea
what could have broke -
I don't see a default route in radvdump at the moment)

config interface 'wan6'
        option ifname '@ge00'
        option proto 'dhcpv6'
        option broadcast '1'
        option metric '2048'
        option reqprefix '60'
        option ip6prefix '2001:Y:X:f0f0::/60' # A different subset
        option ip6prefix '2001:Y:X:fff0::/60' # another subset
        option reqaddress 'try'
#       option clientid 'davedesk' # don't use this param, goes boom.
don't set it in the gui

We hae a long way to go on ipv6, but basic edge functionality is
working pretty good. Just a bunch
of edge cases left to fix.

On Wed, Feb 19, 2014 at 11:38 AM, David Personette <dperson at gmail.com> wrote:
> I check for updates to certain projects each morning... I can quit anytime I
> want... =)
> I hadn't enabled ipv6 again since the hurricane tunnels have been fixed,
> I'll do so tonight. Thanks again.
> --
> David P.
> On Wed, Feb 19, 2014 at 11:29 AM, Dave Taht <dave.taht at gmail.com> wrote:
>> On Wed, Feb 19, 2014 at 11:11 AM, David Personette <dperson at gmail.com>
>> wrote:
>> > I installed 3.10.28-12, and other than some missing packages (bash and
>> > curl
>> Heh. What do you guys do, have a cron job polling for changes to the build
>> dir?
>> :)
>> I was going to sit on that and put out a more polished version sometime in
>> the next couple days.
>> > were what I noticed, and pulled from the previous version
>> I killed some big packages while trying to get a new build done faster.
>> I'll sort through the missing ones and add them back in. (I also just
>> added in squid, per request). Got a big build box donated to use
>> again, post disaster.
>> Does anyone care about cups? (printing?) It was one of those things that
>> just barely works in the first place due to memory constraints and a PITA
>> and I haven't shipped it in a while. Most printers are network capable
>> these days, and what I tend to use the usb port for is odd devices
>> and gps and the like. I'd like to have support for a 3g modem or two...
>> Two concerns of mine are that I killed off udev, which used to manage
>> hotplugging. I'd like to know what, if anything, people are using the usb
>> for, so as to be able to make sure losing udev doesn't break that...
>> > comcast/3.10.28-4). It's working great for me. Throughput on WiFi from
>> > my
>> > laptap to wired server is up, from 7-9MB to 10-12MB. Thank you.
>> I still think there is some tuning to be done on a rrul load, but we had
>> to get the last of the instruction traps out of the way first. As of
>> this morning
>> so far as I know, the "last" ones are gone, but I don't want to jinx it...
>> Did you try ipv6? Default routes are not quite working for me in
>> a couple scenarios.
>> > --
>> > David P.
>> >
>> >
>> > On Tue, Feb 18, 2014 at 5:49 PM, Dave Taht <dave.taht at gmail.com> wrote:
>> >>
>> >> ok, so all the bits flying in loose formation have been rebased on top
>> >> of
>> >> openwrt head, and I've submitted the last remaining differences
>> >> (besides
>> >> SQM) up to openwrt-devel. They immediately took one...
>> >>
>> >> I also went poking through current 3.14rc kernels to find bugs fixed
>> >> there
>> >> but
>> >> not in stable 3.10. Found two more I think. (one elsewhere in the flow
>> >> hash that I had
>> >> just submitted upstream, sigh). Tried to backport sch_fq and sch_hhf,
>> >> failed,
>> >> gave up on tracking pie further.
>> >>
>> >> So I got a new build going, including dnsmasq with dnssec, tested the
>> >> components,
>> >> and was ready to release...
>> >>
>> >> ... when a whole boatload of other stuff landed. Doing a new build
>> >> now...
>> >>
>> >> and taking the rest of the day off.
>> >>
>> >>
>> >> --
>> >> Dave Täht
>> >>
>> >> Fixing bufferbloat with cerowrt:
>> >> http://www.teklibre.com/cerowrt/subscribe.html
>> >> _______________________________________________
>> >> Cerowrt-devel mailing list
>> >> Cerowrt-devel at lists.bufferbloat.net
>> >> https://lists.bufferbloat.net/listinfo/cerowrt-devel
>> >
>> >
>> --
>> Dave Täht
>> Fixing bufferbloat with cerowrt:
>> http://www.teklibre.com/cerowrt/subscribe.html

Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

More information about the Cerowrt-devel mailing list