[Cerowrt-devel] Upgraded to 3.10.38-1, DNS issues?

Aristar LeetMiniWheat at gmail.com
Sat May 10 14:42:46 EDT 2014

I didn't specify any DNS servers so I guess it was using my ISP's dns
servers (verizon FiOS). As I said I didn't realize DNSSEC was enabled
by default now. but even with it disabled it doesn't seem to work out
of the box anymore without a manually set resolv file.

dnscrypt-proxy is working great though (without needing a resolv
file), it runs as a daemon and sets up an encrypted connection to
OpenDNS servers which you then specifcy for dns
forwarding. I suggested this be added to CeroWRT awhile ago but there
wasn't much interest, nor any official packages available, though that
thread I linked above in this thread has a repository and a maintainer
in the forum thread with a source repo.

>Out of interest, which upstream DNS servers were you using when DNSSEC
>was blocked?  I noticed fairly recently that some Wi-Fi networks (Global
>Gossip, using filtered OpenDNS upstream) refused all dnssec-enabled
>requests with NXDOMAIN.  This was testing with a custom-built dnsmasq
>2.70 on Ubuntu, but the same setup works fine behind both CeroWRT and
>other DNSSEC-capable servers that I tried.
>Robert Bradley

On Fri, May 9, 2014 at 12:17 PM, Aristar <LeetMiniWheat at gmail.com> wrote:
> Okay I figured it out. It was DNSSEC I didn't realize it was enabled
> by default so I had to comment out the lines in /etc/dnsmasq.conf but
> I still had to manually specify a nameservers in a separate config
> under LUCI Network>DHCP and DNS>Resolv and Hosts Files>"Resolve file"
> and all is well again.
> Now to set up dnscrypt-proxy again which actually has a repository now
> and instructions for building from source. (Seems more reliable than
> DNSSEC anyways, though I have not read too much on DNSSEC).
> src/gz exopenwrt http://exopenwrt.and.in.net/ar71xx/packages
> https://forum.openwrt.org/viewtopic.php?id=36380&p=1
> On Fri, May 9, 2014 at 5:34 AM, Aristar <LeetMiniWheat at gmail.com> wrote:
>> Sorry if this is a dumb question but I'm not sure what's changed since
>> 3.7.5 but I can't get DNS working. my resolv.conf says, the
>> /tmp/resolv.conf.auto has valid dns servers and I can't resolve
>> anything locally on the router via ssh or on any client device. I CAN
>> get dns LOCAL only if I add a dns server to /etc/resolv.conf but
>> clients using nameserver can't
>> Any ideas? I did a fresh install/clean configs and it isn't working
>> out of the box or with any GUI or manual editing I've tried.

More information about the Cerowrt-devel mailing list