[Cerowrt-devel] how's everybody's uptime?

Sebastian Moeller moeller0 at gmx.de
Sat Nov 8 07:08:31 EST 2014

Hi leetminiwheat (nice handle by the way ;) )
On Nov 6, 2014, at 16:45 , leetminiwheat <LeetMiniWheat at gmail.com> wrote:

> 3.10.50-1 uptime/stability report:
> using as primary gw router for a few months now. primary net usage:
> gaming, and routing net to cable TV boxes via FiOS provided MoCA
> router as secondary router.
> # uptime
> 10:11:56 up 20 days, 20:09,  load average: 0.00, 0.02, 0.04
> nothing strange in dmesg or logread. (though logread only goes back so far.)
> memory usage in htop seems consistent between 27MB and 28MB, no memory leaks.
> sw00/sw10 WiFi performance has been good on both fronts for 2.4ghz and
> 5ghz. I run a WiFi hotspot on gw00. no sign of bug 443
> had to reboot before this due to SQM bug, bandwidth limiting stopped
> working on guest ingress presumably due to many SQM restarts and/or
> wifi channel fiddling. Also recall odhcpd going out of control with
> CPU usage about 2 months ago or something. still have to figure out
> some way to limit max connections for guests so they can't saturate my
> network even with badnwidth limiting, firewall packages seem to lack
> support for what I'd need. I have 6 IFB interfaces right now though,
> any way to clean these up?

Maybe the following will work (repave $CUR_IFB with the IFB you want to get rid of)
	tc qdisc del dev $CUR_IFB root
followed by:
	ip link delete ${CUR_IFB} type ifb
Hopefully that should do the trick. I am curious which SQM you are using stock from cerowrt 3.10.50-1 or an updated version? We tried to fix the spurious IFB generation and should be in much better shape now, only leaking IFBs if either run.sh or stop.sh do not execute fully. I would love independent confirmation that the fixes actually work… 

> mdns responder (avahi-daemon) seems to be working with iPhone to
> Windows 8.1, though iPhone needs to be rebooted for WiFi sync to work
> every darn time. Unsure if iPhone bug or Windows bug or avahi bug.
> seems to advertise all services fine when I checked from a linux box.
> not using ipv6, though @ge00 and odhcpd is enabled still. GW10 and
> babel disabled. gw00 guest/bandwidth limited, and ge00 limited just
> below ISP cap. all fq_codel.

	How well does that work in practice? (Can you effectively shape to more than 60Mbps combined over all directions and interfaces concurrently?)

Best Regards

> Other additional packages I run:
> -OpenSSH client for socks5 proxy ssh session to a remote server w/
> screen for lower latency gaming tunnel. (se00)
> -Miau for IRC bouncer.
> -dnscrypt-proxy server running locally to fetch encrypted dns requests
> and serve locally to dnsmasq working great. I wish this
> package would get pushed upstream, I think it's more secure than
> DNSSEC. or possibly a combination of the two would be best. (still
> unsure how to setup DNSSEC properly).
> On Wed, Oct 1, 2014 at 8:37 AM, Richard Weait <richard at weait.com> wrote:
>> On Sat, Sep 27, 2014 at 1:23 PM, Dave Taht <dave.taht at gmail.com> wrote:
>>> I have thus far been delighted in the stability of 3.10.50-1, how's it
>>> working for all of you?
>> I have to confess that I'm still using. 3.10.41-1 on two devices.
>> up 30 days on one
>> and 39 days on the other
>> _______________________________________________
>> Cerowrt-devel mailing list
>> Cerowrt-devel at lists.bufferbloat.net
>> https://lists.bufferbloat.net/listinfo/cerowrt-devel
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list