[Cerowrt-devel] ath9k WMM not obeying DSCP/TOS flags?

leetminiwheat LeetMiniWheat at gmail.com
Sat Apr 18 02:06:51 EDT 2015

I've tried, to no avail, to get certain traffic to go to the BK and VO
queues via DSCP and/or TOS mangling (with HTB+fq_codel egress/ingress
DSCP stripping/squashing turned OFF, i.e. flags enabled).

Is this a known issue? Or intentional behavior? Or something
misconfigured in qdiscs? Shoving tons of traffic down wifi which
should be DSCP/TOS flagged for BK or VO only puts it in VI or BE from
what I can tell from /sys/kernel/debug/ieee80211/phy0/ath9k/queues and

I've tried -j DSCP --set-dscp xxx in mangle PRE/POST and I see the
MARKing going on in QOS_MARK_$IFACE zone(s), so the traffic is clearly
getting marked for QoS bins

A wireless "expert" friend of mine was saying a lot of WMM issues
weren't fixed until kernel 3.17-3.18?

WMM seems particularly useful for mobile devices and/or crowded
airspace, so I'd like to somehow get this working right.

More information about the Cerowrt-devel mailing list