[Cerowrt-devel] Problems testing sqm

Sebastian Moeller moeller0 at gmx.de
Sat Oct 24 13:21:08 EDT 2015

Hi Dave,

On Oct 24, 2015, at 12:20 , Dave Taht <dave.taht at gmail.com> wrote:

> Another thought is that this hardware agressively does GRO - 64k
> "packets"really messes up htb. We already showed that problem in the
> previous generation.

	Good point. To disable the offloads one needs to disable offloads for all interfaces. The following shell function should do the trick, just run it for all interfaces:

eth_setup() {
    ethtool -K $IFACE gso off
    ethtool -K $IFACE tso off
    ethtool -K $IFACE ufo off
    ethtool -K $IFACE gro off
    if [ -e /sys/class/net/$IFACE/queues/tx-0/byte_queue_limits ]
       for i in /sys/class/net/$IFACE/queues/tx-*/byte_queue_limits
          echo $(( 4 * $( get_mtu ${IFACE} ) )) > $i/limit_max

Save this into a shell file, say my_func.sh, source it from the router’s shell “. ./my_func.sh”, and call “IFACE=eth0 eth_setup” for all interfaces to tackle. I guess we should expose this under luci-app-sqm in a nicer fashion.

But since cerowrt automatically disabled all off-loads and Richard saw his issues also with cerowrt, I am not sure whether this is his issue…

Best Regards

> which we fixed in cake... Turn off all ethernet offloads and try again?
> I have no idea what else is going wrong.
> Dave Täht
> I just lost five years of my life to making wifi better. And, now...
> the FCC wants to make my work, illegal for people to install.
> https://www.gofundme.com/savewifi
> On Fri, Oct 23, 2015 at 6:10 PM, Richard Smith <smithbone at gmail.com> wrote:
>> I have a shiny new Linksys WRT1900ACS to test.
>> I thought it might be nice to start with some comparisons of factory
>> firmware vs OpenWRT with sqm enabled.
>> So I built and installed an openwrt trunk but the results were very
>> non-impressive.  Rrul test reported mulit-seconds of latency and it was
>> equally non-impressive with sqm enabled or disabled.  So I assumed that sqm
>> in trunk on this device must not work yet.  Then I wondered how well sqm in
>> trunk was tested and that perhaps its broken for all devices.
>> So I tested openwrt trunk on my Netgear 3700v2 and saw the same results.
>> Then I tried openwrt cc and got the same results.
>> Finally, I went to the reference implementation: cerowrt 3.10.50-1 on my
>> 3700v2.  Same results.
>> So at this point I'm thinking there's a PEBKAC issue and I'm not really
>> turning it on.
>> Here's my enable procedure:
>> Go the sqm tab in the GUI and set egress and ingress to 10000, set the
>> interface to the upstream interface,  click enable, click save and apply.
>> Everything else is left at default. ie fq_codel and simple.qos.
>> I've also tried a reboot after enabling those settings and then gone back to
>> the gui to verify they were still set.
>> My test setup:
>> Laptop<--1000BaseT-->DUT<--1000baseT-->Server
>> I run netperf-wrapper -H Server -l 30 rrul and look at the 'totals' or 'all'
>> plot.
>> If I run the above with this setup.
>> Laptop<--1000baseT-->Server
>> Then I get the expected 800-900Mbit/s with latencies < 15ms.  So I don't
>> think there's a problem with my test infrastructure.
>> What am I missing and or what's the next step in figuring out whats wrong?
>> --
>> Richard A. Smith
>> _______________________________________________
>> Cerowrt-devel mailing list
>> Cerowrt-devel at lists.bufferbloat.net
>> https://lists.bufferbloat.net/listinfo/cerowrt-devel
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list