[Cerowrt-devel] Problems testing sqm (solved)

Richard Smith smithbone at gmail.com
Sun Oct 25 12:07:52 EDT 2015

On 10/25/2015 11:10 AM, Richard Smith wrote:

> So I started to try and re-create my steps for failure..  I _am_ able to
> duplicate the problem but I'm not able to figure out how.  It seems to
> just come and go irrespective of what I'm doing with the DUT.  I'm
> mostly in then bad state but every so often things work as expected.

I figured it out and now I feel _really_ stupid.  The problem was having 
WiFi enabled on my laptop.

The netperf server is running on a machine which sits on my 192.168.11.x 
network.  I've been testing things by connecting up the DUT WAN to that 
network and then using 192.168.1.x (or 172.30.42.x) as the DUT LAN side.

My wireless network is bridged to 192.168.11.x.. Yes, Yes, I know this 
is bad but I haven't put in the time to figure out how to configure 
things such that all the broadcast stuff like printers and chromecast 
Just Work in a routed world.  The SO gets unhappy with me when they are 
broken and it's difficult to explain the reasoning.  It's on the TODO.

network-manager automatically connects wlan0 to that network.

When I plug up the ethernet cable network-manager sets up eth0 as the 
default route but, doesn't shutdown existing wlan0 connections.  So 
talking to the DUT via ssh or http: works as expected. However, when I run:

netperf-wrapper -H server -l 15 --disable-log -p all rrul

If I forgot to turn off WiFi then I'm completely bypassing the DUT and 
testing my WiFi network instead. "This is not the network you are 
looking for."

Sigh.  Sorry for all the noise.  Thanks for everyones help. Now I'll get 
back to the original task of comparing the performance of the 1900acs 
factory firmware vs openwrt trunk with sqm.

Richard A. Smith

More information about the Cerowrt-devel mailing list