<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    I have been using pie for approximately 3 weeks.<br>
    <br>
    You are correct, in that the outbound speed is about 800 - 900 kb/s.<br>
    <br>
    I shall try what you suggest, but do not know how to express the
    target of 25 ms as a configuration option.<br>
    <br>
    <br>
    <div class="moz-cite-prefix">On 27/12/13 19:15, Dave Taht wrote:<br>
    </div>
    <blockquote
cite="mid:CAA93jw71kavhGDaoGG86iLBC3bfNPwMF9=5T=Km96MXQiw0AQA@mail.gmail.com"
      type="cite">
      <p dir="ltr">Dear fred: are you sticking with pie? I was going to
        suggest you try fq codel with a target 25ms on your outbound.
        (You are at 800kbit or so as best I recall?)</p>
      <div class="gmail_quote">On Dec 27, 2013 11:10 AM, "Fred Stratton"
        <a class="moz-txt-link-rfc2396E" href="mailto:fredstratton@imap.cc"><fredstratton@imap.cc></a> wrote:<br type="attribution">
        <blockquote class="gmail_quote" style="margin:0 0 0
          .8ex;border-left:1px #ccc solid;padding-left:1ex">
          <div bgcolor="#FFFFFF" text="#000000"> I upgraded to 3.10.24-8
            on 2013-12-23.<br>
            <br>
            I modified /etc/fixdaemons, adding<br>
            /etc/init.d/sqm restart<br>
            <br>
            input the appropriate sqm settings, transcribed from aqm<br>
            <br>
            rebooted<br>
            <br>
            and the build works very well. For ADSL2+ here, it is the
            best so far.<br>
            <br>
            <br>
            <div>On 27/12/13 18:55, Dave Taht wrote:<br>
            </div>
            <blockquote type="cite">
              <p dir="ltr">A race condition appears to have crept in...</p>
              <div class="gmail_quote">---------- Forwarded message
                ----------<br>
                From: "Dave Taht" <<a moz-do-not-send="true"
                  href="mailto:dave.taht@gmail.com" target="_blank">dave.taht@gmail.com</a>><br>
                Date: Dec 27, 2013 10:47 AM<br>
                Subject: Re: [Cerowrt-devel] CeroWrt 3.10.24-8 badly
                bloated?<br>
                To: "Richard E. Brown" <<a moz-do-not-send="true"
                  href="mailto:richb.hanover@gmail.com" target="_blank">richb.hanover@gmail.com</a>><br>
                Cc: <br>
                <br type="attribution">
                <p dir="ltr">Probably didn't start sqm properly</p>
                <p dir="ltr">Restart it by hand via /etc/init.d/sqm
                  restart</p>
                <p dir="ltr">tc -s qdisc show dev ge00 </p>
                <p dir="ltr">Should show htb and fq codel.</p>
                <div class="gmail_quote">On Dec 27, 2013 10:36 AM, "Rich
                  Brown" <<a moz-do-not-send="true"
                    href="mailto:richb.hanover@gmail.com"
                    target="_blank">richb.hanover@gmail.com</a>>
                  wrote:<br type="attribution">
                  <blockquote class="gmail_quote" style="margin:0 0 0
                    .8ex;border-left:1px #ccc solid;padding-left:1ex">
                    So I screwed up my courage and replaced my 3.10.18-?
                    firmware in my primary router with 3.10.24-8. That
                    version had worked well as a secondary, so I
                    figured, What the heckÖ Letís give it try.<br>
                    <br>
                    The result was not pretty. I set my link speeds in
                    the SQM page, chose the defaults for the Queue
                    Discipline tab, and link layer to ATM with no
                    additional overhead for my DSL link.<br>
                    <br>
                    Ping times to google are normally ~51-54 msec. But
                    when I fired up <a moz-do-not-send="true"
                      href="http://speedtest.net" target="_blank">speedtest.net</a>,
                    they jumped to 1500-2500 msec. Is there something I
                    should look at before reverting? Thanks.<br>
                    <br>
                    Rich<br>
                    _______________________________________________<br>
                    Cerowrt-devel mailing list<br>
                    <a moz-do-not-send="true"
                      href="mailto:Cerowrt-devel@lists.bufferbloat.net"
                      target="_blank">Cerowrt-devel@lists.bufferbloat.net</a><br>
                    <a moz-do-not-send="true"
                      href="https://lists.bufferbloat.net/listinfo/cerowrt-devel"
                      target="_blank">https://lists.bufferbloat.net/listinfo/cerowrt-devel</a><br>
                  </blockquote>
                </div>
              </div>
              <br>
              <fieldset></fieldset>
              <br>
              <pre>_______________________________________________
Cerowrt-devel mailing list
<a moz-do-not-send="true" href="mailto:Cerowrt-devel@lists.bufferbloat.net" target="_blank">Cerowrt-devel@lists.bufferbloat.net</a>
<a moz-do-not-send="true" href="https://lists.bufferbloat.net/listinfo/cerowrt-devel" target="_blank">https://lists.bufferbloat.net/listinfo/cerowrt-devel</a>
</pre>
            </blockquote>
            <br>
          </div>
        </blockquote>
      </div>
    </blockquote>
    <br>
  </body>
</html>