[Codel] R: Making tests on Tp-link router powered by Openwrt svn

Alessandro Bolletta alessandro at mediaspot.net
Fri Dec 21 05:19:35 EST 2012

Hi jonathan,

This is how i configured the testbed:

I have a windows 8 laptop connected directly on the tplink/openwrt router. Tplink is also connected to a gigabit switch.
So, i thought to make some file uploads from a linux samba file server connected to the switch to my windows 8 laptop, through SMB protocol (which uses TCP).

In order to create the bottleneck, tplink router has two 10/100mbits ports. So, i restricted the port connected to the switch to 10Mbit half duplex.

Also, i tried to decrease interval and target options in order to obtain a latency, for connections estabilished while upload is flowing, lower that 5 ms.
So i set target at 2ms and interval to 5ms.
So this is the schema:


where tplink is routing subnets.

If i ping "linux server" i get very high latencies...and if i ping other PCs connected to the switch, i get about 10ms latencies.

I also tried to lower target at 1 ms and interval at 2ms, but i see the same effects.

If i disable fq_codel, i get always the same result.

Can you explain me where i'm going wrong?


Da: Jonathan Morton [mailto:chromatix99 at gmail.com]
Inviato: giovedì 20 dicembre 2012 19.08
A: Alessandro Bolletta
Cc: Codel at lists.bufferbloat.net
Oggetto: Re: [Codel] Making tests on Tp-link router powered by Openwrt svn

Is the bottleneck actually at your router, or (as is more usual) at the modem?

- Jonathan Morton
On Dec 20, 2012 7:57 PM, "Alessandro Bolletta" <alessandro at mediaspot.net<mailto:alessandro at mediaspot.net>> wrote:
Hi everybody,
Today i made some tests on my tplink home router powered by the lastest snapshot build of Openwrt.
So, i configured tc to make fq_codel the default queuing algorithm for 2 eth ports available on the router (leaving unchanged default values).
So, i started some TCP sessions through my Windows client and I loaded the available bandwidth...but the test wasn't going as expected because i experienced packet loss and high delays as i did when the default simple fifo queue was the default queue.
Is there something that i'm not understanding?

Alessandro Bolletta
Codel mailing list
Codel at lists.bufferbloat.net<mailto:Codel at lists.bufferbloat.net>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.bufferbloat.net/pipermail/codel/attachments/20121221/abe42e61/attachment-0002.html>

More information about the Codel mailing list