[Cerowrt-devel] cerowrt-3.10.2-1 dev release + owamp

Sebastian Moeller moeller0 at gmx.de
Fri Jul 26 05:54:01 EDT 2013

Hi Fred, hi List

On Jul 26, 2013, at 08:21 , Fred Stratton <fredstratton at imap.cc> wrote:

> I can certainly confirm this, having spent several fruitless hours with the build.
> 6in4 remains broken for henet.
> dnsmasq appears not to recognise additional domain name servers. The ISP I use has a very slow domain name service, to which the system now defaults. The consequence of this is that opkg times out, and no packages can be installed.
> It is still not possible to watch a video stream and download files simultaneously on an ADSL line.

I can not comment on most of your issues, but I might have some information about the ADSL issue. I only got around to test 3.10.1-1 but I suspect that there are no changes in the relevant packages between these versions. I had a few issues with getting my ADSL line (atm carried adsl2+) to work reasonably; maybe some of these issues are at play in your setup as well. 

Anyway, it turned out to have probably two main reasons:

1) It looks that the AQM luci interface does not really propagate the requested bandwidth down to simple_qos.sh (the version Toke's AQM package supplies), to get this working I had to edit the bandwidth defaults in /usr/lib/aqm/functions.sh to make it work at all. (I then switched back to the stand alone simple_qos.sh; no time yet to debug why the luci-fied version did not honor the up- and download speeds from the gui)
That helped a lot. Enabling simple_qos.sh's PPPOE option did not improve things to where I expected them.

2) It seems HTB's issues with regards to the ATM carrier (and potentially per packet overhead do not seem fully solved yet. I side stepped this issue by resorting to handle these issues with the more generic td-stab mechanism:
I added the following to simple_qos.sh (my line has 40 bytes of encapsulation overhead, but linux already accounts for the 14bytes ethernet header, so the additional overhead is 26, you probably know your overhead already*):
	EGRESS_STAB_STRING="stab mtu 2048 tsize 128 overhead 26 linklayer atm"
	INGRESS_STAB_STRING="stab mtu 2048 tsize 128 overhead 26 linklayer atm"

then I changed egress() from:
	$TC qdisc add dev $IFACE root handle 1: htb default 12
	$TC qdisc add dev $IFACE root handle 1: ${EGRESS_STAB_STRING} htb default 12

and ingress() from:
	$TC qdisc add dev $DEV root handle 1: htb default 12
	$TC qdisc add dev $DEV root handle 1:  ${INGRESS_STAB_STRING} htb default 12

that again helped a lot.

3) I also turned of polipo on my wndr3700 v2 assuming that the device has to little memory and flash storage to allow for polipo to be actually useful. I intend to supply polipo with a larger backing store and enable it again in due time.

These changes turned maximum ping RTTs under load from initially up to almost 6 seconds (avg ~ 250ms) down to 226ms (avg 26ms). I just measured the ping times to a near host (RTT ~24ms ) while saturating the upload with a single large transfer and stressing the download by opening around 100 media heavy browser tabs at once

In case you test these changes I would love to hear whether this improves your situation or not.

*) Note: thee is no universal ADSL overhead, it depends on the encapsulation method used by your ISP, so one either needs to look up the required information (see: http://ace-host.stuart.id.au/russell/files/tc/tc-atm/ and http://www.dsm.fordham.edu/cgi-bin/man-cgi.pl?topic=tc-stab&ampsect=8 and http://www.faqs.org/rfcs/rfc2684.html) or figure it out empirically.

Best Regards

> On 26 Jul 2013, at 06:20, Dave Taht <dave.taht at gmail.com> wrote:
>> sysupgrade -n doesn't work with this release. Stay away. I have a new
>> build of 3.10.3-1 and am trying to fix it...
>> I did find the problem on the ubnt builds - I'd switched to the new
>> babeld from quagga, but failed to install it by default.
>> in openwrt trunk, elliptic curve has been enabled in openssl. It's
>> long past time we enable https for configuration by default, and might
>> as well figure out how to turn perfect forward secrecy on as well in
>> the post-snowden era.
>> owamp seemingly works well, with a couple glitches here and there. I
>> got to where the lab was synced to about 1ms resolution... and 5 more
>> gpses arrived today....
>> _______________________________________________
>> Cerowrt-devel mailing list
>> Cerowrt-devel at lists.bufferbloat.net
>> https://lists.bufferbloat.net/listinfo/cerowrt-devel
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list