[Cerowrt-devel] 3.10.32-4 issues

Sebastian Moeller moeller0 at gmx.de
Wed Mar 5 18:52:49 EST 2014

Hi Dave, hi List,

On Mar 6, 2014, at 00:34 , Dave Taht <dave.taht at gmail.com> wrote:

> those zones appear empty in the gui because we use the + syntax to join them,
> which the gui cannot interpret.

	Ah, I had not noticed that these were always empty, sorry.

> there are a multitude of issues with 3.10.32-X at the moment. I am at
> a conference. Felix is on vacation. Don't try it.

	Too late ;) but since I could not get to work I reverted to 3.10.28-14 which worked okay before, will wait for a go signal before trying 3.10.32+ again… (The few things on my SQM todo list will work just as well with the 3.10.28, so I really just wanted to see whether the TX hangs would be gone with 3.10.32, but they still remain...)

> I keep hoping to
> spend an hour with the openwrt devs here to see everything that is
> going wrong now that hncp was nearly unanimously
> approved by the homenet working group as the way forward (yea!)
> The last patches for dnsmasq landed last week and simon tells me he
> plans a stable release soon.

	All this sounds quite promising…

Best Regards

> On Wed, Mar 5, 2014 at 10:17 PM, Sebastian Moeller <moeller0 at gmx.de> wrote:
>> Hi All,
>> I just upgraded to 3.10.32-4 and locally all looks quite well. Both my macbook and my nexus 4 get stable connections to cerowrt over the 5GHz radio (HT40+ channel 44 country code: DE), also the machine on se00 gets a decent address. That is all machines get decent IP4 addresses, only cerowrt gets a working ipv6 address.
>>        Unfortunatelly the only machine that can reach the internet is the cerowrt itself, none of the connected machines can reach the internet (they can reach each other just fine)
>>        Here is a bit information from the linux host on se00:
>> moeller at happy-horse:~> sudo /sbin/ip -4 r l
>> default via dev eth0
>> dev lo  scope link
>> dev eth0  scope link
>> dev eth0  proto kernel  scope link  src
>> moeller at happy-horse:~> ifconfig
>> Absolute path to 'ifconfig' is '/sbin/ifconfig', so running it may require superuser privileges (eg. root).
>> moeller at happy-horse:~> sudo /sbin/ifconfig
>> eth0      Link encap:Ethernet  HWaddr 28:92:4A:30:5D:BE
>>          inet addr:  Bcast:  Mask:
>>          inet6 addr: fe80::2a92:4aff:fe30:5dbe/64 Scope:Link
>>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>          RX packets:478 errors:0 dropped:0 overruns:0 frame:0
>>          TX packets:549 errors:0 dropped:0 overruns:0 carrier:0
>>          collisions:0 txqueuelen:1000
>>          RX bytes:50463 (49.2 Kb)  TX bytes:163720 (159.8 Kb)
>>          Interrupt:18
>> lo        Link encap:Local Loopback
>>          inet addr:  Mask:
>>          inet6 addr: ::1/128 Scope:Host
>>          UP LOOPBACK RUNNING  MTU:65536  Metric:1
>>          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
>>          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
>>          collisions:0 txqueuelen:0
>>          RX bytes:1312 (1.2 Kb)  TX bytes:1312 (1.2 Kb)
>> moeller at happy-horse:~> ping -c 10 www.google.com
>> PING www.google.com ( 56(84) bytes of data.
>> --- www.google.com ping statistics ---
>> 10 packets transmitted, 0 received, 100% packet loss, time 8999ms
>> moeller at happy-horse:~> sudo /sbin/ip -4 a l
>> 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
>>    inet brd scope host lo
>>       valid_lft forever preferred_lft forever
>> 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
>>    inet brd scope global eth0
>>       valid_lft forever preferred_lft forever
>> moeller at happy-horse:~> sudo /sbin/ip -4 route
>> moeller at happy-horse:~>
>> To me this looks reasonable and I am unsure why the machine does not reach the internet. Interestingly on the first login to cerowrt routing seemed to have worked, but once I applied the set of changes I typically apply to customize cerowrt for my home network routing somehow went bust.
>> I just noticed that the lan and guest zones were empty, so I ant an reassigned them, but still the connected computers can not reach the internet. If there is anything I can do to debug this, please let me know, otherwise I will ref lash the router back to 3.10.28-16 tomorrow...
>> Best Regards
>>        Sebastian
> -- 
> Dave Täht
> Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

More information about the Cerowrt-devel mailing list