[Cerowrt-devel] Latest build test - new sqm-scripts seem to work; "cake overhead 40" didn't

Alan Jenkins alan.christopher.jenkins at gmail.com
Fri Jun 19 16:57:34 EDT 2015

On 19/06/15 21:51, Dave Taht wrote:
> hmm?
> opkg update; opkg install strace ?

sorry.  Yes, that's what I did; I left that part out.  strace isn't 
installed by default, I tried to install it at some point, got "not found"

same error with tc command from tc-adv if I try to reinstall it

> I have done several builds in this dir in the last few days, however,
> and that could be messing you up.

Ok, that's it.

root at mortar:~# grep musl `which strace`

Don't think that's going to work on my box somehow :)

root at mortar:~# grep -i uclibc `which which`

>   I am trying to get a good build now,
> but it is blowing up on needing libssp for some reason.
> I really picked the wrong time to try and get something stable built.
> This was my last big chance to deploy a few routers in test before
> starting to travel extensively.
> On Fri, Jun 19, 2015 at 1:40 PM, Alan Jenkins
> <alan.christopher.jenkins at gmail.com> wrote:
>> On 19/06/15 21:12, Dave Taht wrote:
>>> re: keywords: it may be that the tc-adv package is not correctly
>>> overriding the tc package. Sigh.
>>> try a opkg update; opkg remove tc-adv; opkg install tc-adv and see if
>>> you get the keywords.
>> Or I screwed up and the box is running the previous build?
>> $ ssh root at mortar
>> BusyBox v1.23.2 (2015-06-12 19:22:15 PDT) built-in shell (ash)
>> I hope so because the alternative is debugging this-
>> root at mortar:~# strace
>> -ash: strace: not found
>> root at mortar:~# echo $?
>> 127
>> (same happens when installing tc-adv)
>> Alan

More information about the Cerowrt-devel mailing list