[Cerowrt-devel] Problems testing sqm

Sebastian Moeller moeller0 at gmx.de
Fri Oct 23 13:38:57 EDT 2015

Hi Richard,

On Oct 23, 2015, at 18:10 , Richard Smith <smithbone at gmail.com> wrote:

> I have a shiny new Linksys WRT1900ACS to test.

	Nice, I am quite curious how this performs...

> I thought it might be nice to start with some comparisons of factory firmware vs OpenWRT with sqm enabled.

	Good thought.

> So I built and installed an openwrt trunk but the results were very non-impressive.  Rrul test reported mulit-seconds of latency and it was equally non-impressive with sqm enabled or disabled.

	Less good result.

>  So I assumed that sqm in trunk on this device must not work yet.  Then I wondered how well sqm in trunk was tested and that perhaps its broken for all devices.

	I believe it works reasonable well, at least there are no reports about major failures known and only minor fixes outstanding.

> So I tested openwrt trunk on my Netgear 3700v2 and saw the same results. Then I tried openwrt cc and got the same results.

	This is suspicious.

> Finally, I went to the reference implementation: cerowrt 3.10.50-1 on my 3700v2.  Same results.

	Now the default sqm-scripts in cerowrt is ancient, but all the same looks weird...

> So at this point I'm thinking there's a PEBKAC issue and I'm not really turning it on.

	Well, it might be lack of documentation… (on my todo list, but way way back there, sorry).

> Here's my enable procedure:
> Go the sqm tab in the GUI and set egress and ingress to 10000, set the interface to the upstream interface,  click enable, click save and apply. Everything else is left at default. ie fq_codel and simple.qos.
> I've also tried a reboot after enabling those settings and then gone back to the gui to verify they were still set.

	The best test (for validity of the configuration) is to run the following on the router and preferably copy and post the output to this thread:

1) tc -d qdisc
2) /etc/init.d/sqm stop
3) tc -d qdisc
4) /etc/init.d/sqm start
5) tc -d qdisc

> My test setup:
> Laptop<--1000BaseT-->DUT<--1000baseT—>Server

	What does DUT expand to?

> I run netperf-wrapper -H Server -l 30 rrul and look at the 'totals' or 'all' plot.

	I routinely look at the all_scaled plot as well as the totals, often the time course offers some explanation why the total looks bad, maybe you could post the plot here?

Best Regards

> If I run the above with this setup.
> Laptop<--1000baseT-->Server
> Then I get the expected 800-900Mbit/s with latencies < 15ms.  So I don't think there's a problem with my test infrastructure.
> What am I missing and or what's the next step in figuring out whats wrong?
> -- 
> Richard A. Smith
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list