[Cerowrt-devel] ***UNCHECKED*** Re: Problems testing sqm (solved)

Richard Smith smithbone at gmail.com
Mon Oct 26 17:54:32 EDT 2015

On 10/26/2015 10:30 AM, Sebastian Moeller wrote:
> Hi Toke,
> On Oct 26, 2015, at 14:50 , Toke Høiland-Jørgensen <toke at toke.dk>
> wrote:
>> Sebastian Moeller <moeller0 at gmx.de> writes:
>>> So, I have no recipe for home-brew, but I use the attached as
>>> local ports collection under macports to get flent to run:
>> You mind if I put this tutorial into the Flent docs?
> Not at all; I am not sure whether a) this is the minimal set and b)
> whether it fully works as advertised, so maybe waiting for Richards
> potential success/failure report might be prudent?

The homebrew part turned out to be pretty easy.

Edit the netperf.rb file to include --enable-demo


brew install netperf.rb --build-from-source

What was much more involved was getting the Mac to a place where you 
could actually build programs.  Have to update Xcode, agree to license 
agreements, and then install command line tools.

'brew doctor'

Is super helpful in sorting all that out.  I see why they had to create it.

BUT, The netperf compile will fail when using --enable-demo.  See here:


So in the end I had to resort to extracting the tarball and editing the 
source to remove the inline on the problematic functions and then good 
ol' ./configure; make; sudo make install;  Which surprisingly worked.  I 
think thats because 'brew doctor' sorted out all the stuff that would 
have otherwise been broken.

And then finally 'brew install fping'

So now I've got flent working now on the Mac Air.

I should also mention that 'brew install qt' is necessary if you want to 
show plots.

Richard A. Smith

More information about the Cerowrt-devel mailing list