[Cerowrt-devel] Linksys wrt1900acs rrul traces

Dave Taht dave.taht at gmail.com
Thu Apr 7 11:24:38 EDT 2016

The default firmware is quite horrificly bad, isn't it? Total
starvation of anything but the first flow, for example, in the native
Do you have the exact version number of the 1900ac's default firmware
you tested.

(I've seen it fall apart on 2 flows, too). I can hardly imagine the
number of users that don't wipe out the default firmware and just live
with this *crap*.

However, I'd have recommended you try 900mbit to see if cake/etc does
the right things, not 975mbit.

Dave Täht
Let's go make home routers and wifi faster! With better software!

On Thu, Apr 7, 2016 at 6:58 AM, Richard Smith <smithbone at gmail.com> wrote:
> A while ago I mentioned that I purchased a Linksys wrt1900acs and I was
> going to do some comparisons of speed/rrul for stock firmware and stuff
> running sqm.
> It took a while to happen but I finally got it done.  I was stalled for a
> long time because for a while OpenWRT was not complete for this router.  It
> would boot but you could not (easily) return to the factory firmware as
> updates via the OpenWRT web interface did not work.
> Command line updates still worked though periodically I would build dd head
> and see if it got fixed.  Finally one weekend I decided to dig in and figure
> out what was going wrong and discovered that someone else beat me to it and
> it all was working now.
> The following flent rrul runs were run here on my local Gbit network (pretty
> quiet) using with OpenWrt Designated Driver r49051 / LuCI Master
> (git-16.081.38806-6b9a743) + Cake installed.
> Cake installed via the instructions here:
> http://www.bufferbloat.net/projects/codel/wiki/Cake#Installing-CAKE-out-of-tree-on-OpenWrt-rough-instructions
> For these tests I had the inbound and outbound limits set to 975000 kbps.
> 975000 was somewhat arbitrary.  I wanted it below 1Gbps enough that I could
> be sure it was the router as the limit but yet fast enough that I would be
> able to see the peak transfer rates.
> Test setup is:
> Laptop<-->wrt1900acs<--->Gbit Switch<--->Netperf server
> Prior to running the tests I did trial runs without the wrt1900acs in the
> chain to verify every thing worked at Gbit speeds.
> I ran the rrul test for each of the SQM settings at least 5 times.  For
> layer cake and piece of cake each had a run with results that were way off
> from the previous run.  I'm assuming this is some yet to be fixed issue and
> so I ran it 1 more time so that there were 5 runs with similar results.
> All the raw files are in this tarball:
> https://drive.google.com/file/d/0B-P0wCbNmKvAWmRUSzNMdXpUOFE/view?usp=sharing
> Hope this is helpful.  I'll be happy to run any additional tests if someone
> wants more.
> --
> Richard A. Smith
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list