[Cerowrt-devel] shaggy dog story on 3.8.8-4 experiences

Dave Taht dave.taht at gmail.com
Tue Apr 30 16:45:08 EDT 2013

On Tue, Apr 30, 2013 at 12:29 PM, Michael Richardson <mcr at sandelman.ca> wrote:
> On my todo list was moving from 3.3 installed last summer to 3.8.8-4,
> via the forklift method of configuring a new device and installing it.
> Something was up on my network, and I discovered that I could not ssh
> into my 3800, and so on Sunday afternoon when I figured that I wasn't
> going to interrupt anything, I rebooted it from the web interface, which
> was still working.
> Sadly, it did come back, but it wasn't in the configuration I expected,
> and I could not access it.  I'm way too used to having a serial console
> on everything...
> I was about to flash it, when I thought... good time for 3.8.8-4, so
> I put that one in place, and uploaded my config back from November,
> and...

yea, well, I make no warrantees about configs being backward
compatible. Sorry, tons of stuff has changed.

> that unit promptly went away.  I've since concluded after
> examining that configuration, that this wasn't the last and final
> configuration, and that likely the previous unit ("55" I call it) had
> never properly saved it's config.
> A few hours later (BBQ-Pizza and bed time stories were in the way), I
> got things back to normal....  I've now extracted the config backup into
> a git tree and actually read it to confirm that it's sane.
> My observations:
> 1) I find it really confusing to have a default route on each interface
>    details.  It's clear to me now that I want to only set the default
>    route on the interface which is my uplink, but it seems like maybe
>    I should set the same thing on the other interfaces, but that leads
>    to bad things.

The default route is a bad leftover from the days nobody could decide
on a routing protocol. Which is still the days.

In the case of the default gw on the router, it comes from the
dhcp/dhcp-pd client  getting the default gw from it's upstream.

In the case of the default gw on the clients, it gets it from it's
dhcp server, (dnsmasq) and is specific to the interface ip the
interface is on. Since this is a /27, you get things like .1 or .65 or

Me I stopped dealing with this sort of nonsense years ago and just run
a routing daemon on everything and ignore default routes except what I
get from that....

> 2) I don't think that I got RAs turned on properly on at least one of
>    my interfaces.  I did do it today with unit 55 on the bench, so I'm
>    unclear what I did wrong.

The new RA support is not fully integrated with the gui yet. dnsmasq
2.66 just landed in openwrt head a few days ago, so expect uci and gui
changes there soon.

So how cero does it is in /etc/dnsmasq.conf and there are a variety of
ways to do it.
> 3) mDNS does not announce the actual hostname that I gave to the device
>    only "cerowrt".

that is presently set in /etc/avahi/something.

The long term plan has become to follow the mdnsext work and fold it
into dnsmasq. Probably. configured with something via a ubus
interface, which certainly includes getting the hostname right. It
looks like simon finally got funded to do the dnssec work so I don't
expect mdsnext to even start thinking about happening before the next
ietf meeting unless someone else gets hot on it.

> 4) I guess the "prefix routed to this device for other interfaces" is
>    the beginnings of 6204/homenet support.  I'm unclear if it makes
>    sense for it to be settable on multiple interfaces, at least not
>    I think it belongs in the advanced settings pane.

Not sure what you mean. I don't really get the 6relayd stuff.

> 5) I did get prefixes assigned to interfaces... alas, it duplicated
>    prefixes which were already assigned to other interfaces!!!
>    I did setup the hints, but perhaps not for all interfaces.

I'm not sure what you are talking about here. ipassign 64 will take
the 64 hint and assign something to it.

>    At least one prefix is behind another router, so this router can not
>    see that prefix is already in use.  Suggestion: start at highest
>    number available and work downwards.

Two interior prefix allocation methods have been described by the
homenet and hipnet rfcs. openwrt follows neither at present.

>    These assignments should probably go somewhere near the DHCP device
>    assignment list.
> 6) is there anything between complete flash and boot?
>    If I hold down "factory reset" until it's yellow, what does that
>    mean?  I'd like a "reset to LAN-1 has no-VLANs, just DHCP+v6-ULA-RA"
>    and configuration is ignored, but is still present.  Is that
>    possible?


> 7) I tried the AQM page, and I think it worked.


tc -s qdisc show dev ge00

will show htb and fq_codel in that case.
> 8) I can't make the firewall do what I want, given that I have routed
>    public IPv4, so I wind up just writing iptables command in the
>    firewall.user file...

yea, that's become such an uncommon case....

>    That's also where I removed the /64 routes for the prefixes that were
>    assigned to the wrong interfaces...

I think this is a little overthought, but ok....
> --
> ]               Never tell me the odds!                 | ipv6 mesh networks [
> ]   Michael Richardson, Sandelman Software Works        | network architect  [
> ]     mcr at sandelman.ca  http://www.sandelman.ca/        |   ruby on rails    [
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

More information about the Cerowrt-devel mailing list