[Cerowrt-devel] breaking off a port off the vlan correctly?

William Katsak wkatsak at gmail.com
Thu Jan 3 16:17:50 EST 2013


I didn't get really far into this, but I recently did the following with 

DSL Modem -> Cero router -> Trunk two VLANS through port 1 -> Managed 

On the managed switch, I made some of the ports part of VLAN 100, and 
others part of VLAN 200.

VLAN 100 lets a Windows server do DHCP/DNS, and VLAN 200 lets dnsmasq do 
it (its like a "guest" network).

I can route between the networks with no issues, and set firewall rules 
as I wish. I did this by splitting the LAN port into two VLANs in the 
GUI, setting rules for DHCP, etc. accordingly, and then passing both 
VLANS tagged through port 1 on the switch.

This is a little different than what you propose, but should work 
exactly the same if you were to break the VLANs onto two individual 
ports of the switch. Is there some fundamental difference that I am missing?

-Bill Katsak

On 01/03/2013 03:31 PM, Dave Taht wrote:
> One of the things I've long ignored, despite the popularity of it, is
> vlan stuff.
> I care, like everything else, it's just not currently a high priority
> for me to deal with high rate vlan traffic.
> But: I just had a need to connect two entirely separate networks
> together. Being me I just slammed a routed dreamplug between the two
> lans (which just worked five minutes after I compiled babeld and
> turned off getting default gateways from dhcp), but it seems saner to
> just remap one of the ports on a wndr3800 to be its own ethernet
> device (and keep hacking BQL onto the dreamplug, which is what I have
> it for)
> current config:
> default gw box<->  cerowrt<->  dreamplug<->  other network
> desired config:
> default gw box<->  cerowrt<->  dedicated port<->  other network
> However, in trying to do that, several ways, I made bricks.
> Wrong way #1: turn on vlan support, create an untagged vlan #2 on port
> #3 from the switch, disable port #3 from vlan 1, create an interface
> for it (I did all this via the gui), rebooted...
> The box stopped serving dhcp entirely. IPv4 stopped too. I did see
> ipv6 traffic...
> Left off vlan support, never saw any traffic on the broken out port,
> dhcp stopped working on ethernet entirely but stayed up on wifi... I
> tried various combinations of using se00.1 and se00.2 to similar
> non-effect...
> Sigh. In reading up on this on openwrt's web site I'm even more
> confused than i was before.
> I seem to recall that other parties have tried this and went through
> hell, too...
> Anybody got this to work?
> Secondly: My assumption is that you run fq_codel on the underlying
> interface, not the vlan, am I correct in this?

More information about the Cerowrt-devel mailing list