[Cerowrt-devel] netflix through a sony BDP-S185 blue-ray player

Dave Taht dave.taht at gmail.com
Wed Mar 19 22:17:33 EDT 2014

On Wed, Mar 19, 2014 at 6:32 PM, Jim Reisert AD1C
<jjreisert at alum.mit.edu> wrote:
> I meant to add:
> I tried a WiFi connection to my wife's Apple AirPort Time Capsule.
> This device is connected via an Ethernet cable to my WNDR3800 router.
> I get the same error message.

Please enable upnp in the router. It really wouldn't surprise me if it
was required for some operations.

>> I am about to tear my hair out!
>> My WNDR3800 is running:
>>      CeroWrt Toronto 3.10.32-9 / LuCI Trunk (git-c9c65b3)
>> Thinking my existing Sony Blu-ray player (or USB wireless adapter) was
>> at fault, I picked up a Sony BDP-S5100 player on the way home tonight.
>>  I can get through the network setup, network status looks good and it
>> even claims the Internet is working now (whereas my other player would
>> say Failed).  But I can't download the network update or any
>> download/update content.  I went into the Network Diagnostics.  IPV6
>> test passes with flying colors.

Sony does ipv6 now? Cool.

>IPV4 test fails with:

The only thing I'd tried was a blueray player to netflix.

>>     Cannot communicate with DHCP Server

on the router (do this on a fairly idle network so the capture isn't too big)

cd /tmp
tcpdump -w sony.cap -s 1514 -i se00
reboot the blueray player, have it fail
control-c to abort the dump
scp the sony.cap somewhere I can look at it
>> The advanced network settings say that IPV4 has priority.
>> I am at a loss as to what to try next.
> --
> Jim Reisert AD1C, <jjreisert at alum.mit.edu>, http://www.ad1c.us

Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

More information about the Cerowrt-devel mailing list