[Cerowrt-devel] Problems testing sqm

David Lang david at lang.hm
Fri Oct 23 13:15:19 EDT 2015

with the wrt1900ACS, the WAN ethernet is connected to a switch before connecting 
to the wire. I believe that this causes some issues with the sqm default setup 
(or is it with the fq_codel?)

David Lang

On Fri, 23 Oct 2015, Dave Taht wrote:

> you are most likely applying the qdisc to the wrong ethernet device or
> ethernet vlan.
> Dave Täht
> I just lost five years of my life to making wifi better. And, now...
> the FCC wants to make my work, illegal for people to install.
> https://www.gofundme.com/savewifi
> On Fri, Oct 23, 2015 at 6:10 PM, Richard Smith <smithbone at gmail.com> wrote:
>> I have a shiny new Linksys WRT1900ACS to test.
>> I thought it might be nice to start with some comparisons of factory
>> firmware vs OpenWRT with sqm enabled.
>> So I built and installed an openwrt trunk but the results were very
>> non-impressive.  Rrul test reported mulit-seconds of latency and it was
>> equally non-impressive with sqm enabled or disabled.  So I assumed that sqm
>> in trunk on this device must not work yet.  Then I wondered how well sqm in
>> trunk was tested and that perhaps its broken for all devices.
>> So I tested openwrt trunk on my Netgear 3700v2 and saw the same results.
>> Then I tried openwrt cc and got the same results.
>> Finally, I went to the reference implementation: cerowrt 3.10.50-1 on my
>> 3700v2.  Same results.
>> So at this point I'm thinking there's a PEBKAC issue and I'm not really
>> turning it on.
>> Here's my enable procedure:
>> Go the sqm tab in the GUI and set egress and ingress to 10000, set the
>> interface to the upstream interface,  click enable, click save and apply.
>> Everything else is left at default. ie fq_codel and simple.qos.
>> I've also tried a reboot after enabling those settings and then gone back to
>> the gui to verify they were still set.
>> My test setup:
>> Laptop<--1000BaseT-->DUT<--1000baseT-->Server
>> I run netperf-wrapper -H Server -l 30 rrul and look at the 'totals' or 'all'
>> plot.
>> If I run the above with this setup.
>> Laptop<--1000baseT-->Server
>> Then I get the expected 800-900Mbit/s with latencies < 15ms.  So I don't
>> think there's a problem with my test infrastructure.
>> What am I missing and or what's the next step in figuring out whats wrong?
>> --
>> Richard A. Smith
>> _______________________________________________
>> Cerowrt-devel mailing list
>> Cerowrt-devel at lists.bufferbloat.net
>> https://lists.bufferbloat.net/listinfo/cerowrt-devel
> _______________________________________________
> Cerowrt-devel mailing list
> Cerowrt-devel at lists.bufferbloat.net
> https://lists.bufferbloat.net/listinfo/cerowrt-devel

More information about the Cerowrt-devel mailing list