[Cerowrt-devel] update on that nuc I was fighting with

Dave Taht dave.taht at gmail.com
Wed Apr 13 20:11:44 EDT 2016

Hoo, boy, did I have issues. I finally got around to trying to get it
up and running linux.

For reference, this was the:

- Jetway NU93-2930 NUC Form Factor Intel Celeron N2930 SoC Bay Trail 2
Intel LAN, 2 Display, 2 x HDMI, 1 x SATA2 port, full-size mSATA,
half-size mini-PCIE, 1 External COM, 3xUSB2, 1xUSB3, Audio, 9V-24V
DC-in (size 4" x 4" x 1.5").

which I got from amazon:


This came with an intel wifi card that I pulled out and tried to
replace with an ath10k.

1) Sometimes the hdmi wouldn't work (it also did not work on either of
my admittedly older monitors really at all. So I bought a new monitor
to get it up, and maybe I got lucky, but that new monitor "just

Well, it turns out there is a BIOS fix here, which I have not installed yet.


2) No linux OS I tried would write a workable EFI boot area for it
until I tried ubuntu 16.04 beta last night. There is no way to turn
EFI off, either.

3) I'd tried to use a msata + raid to sata adaptor.

this is usually not recognized on a soft boot, and the thing drops to
an EFI shell

the raid component (mirroring) would work sometimes, and other times
it would fall back on
the "fast mode" which joins the two cards together serially. Naturally
this doesn't work either.

I am going to ditch this idea entirely as a well intentioned
experiment for making something more reliable that actually made it
more complex with more failure modes.

I'm going to skip trying one of these, also.


4) It has a full-length msata slot - and a half length pci-e slot.

Despite these sharing a connector type the big slot appears to be
msata only. There is no jumper or bios setting to change it to
something else.

I have had nucs that had the full length slot be mini-pcie capable
before, but not this one,


Of these, this last appears the most damning - without a full length
mini-pcie slot, it's mostly not useful for my purposes. I DID need a
router/delay box, but I was hoping to also feed it the ath10k full
length card. Neither long form mini-pcie cards I tried in it worked.

BQL support works, at least. It's more than fast enough to forward at
a gigabit, and cake can shape to a gbit also. It gets pretty warm when
doing a big compile, but is otherwise silent.

So it is suitable as a non-wifi x86 based router so long as you are
willing to install a very recent linux os on it, and a half length
wifi card. And go msata

(Or perhaps pfsense has better EFI, I didn't try it, am not going to...)

Ah, well, off to review all the other recommendations on the list, I'd
really hoped to get this box up on the ath10k this past week. Also
somewhat tried was an intel galeio board...

Dave Täht
Let's go make home routers and wifi faster! With better software!

More information about the Cerowrt-devel mailing list